Ewon TechForum
Providing technical solutions to technical requests


S7-1200 - Tag address configuration
a123456789Z Offline
Member
#1
Hi,

I have to communicate between an Ewon "Flexy 102" and a Siemens PLC "S7-1200", and I just want to make a little verification about tags' configuration before doing it (To don't lose time trying multiples configuration)

First, the server name should be : S73&400 ?

     -If I want to read a Real, at address 40, in the DB1200, the Address I want to configure is DB1200F128. Concerning the Type I thought of choosing Floating-> Is that right ?
     -If I want to read an Integer, at address 30, in the DB20, the Address I want to configure is DB20W30. Concerning the Type I thought of choosing Integer-> Is that right ?
     -If I want to read a Boolean, at address 4, in the DB46, the Address I want to configure is DB46B4. Concerning the Type I thought of choosing Boolean-> Is that right ? 



Thank you a lot Smile
Reply

simon Offline
eWON Support
#2
First, the server name should be : S73&400Yes

     -If I want to read a Real, at address 40, in the DB1200, the Address I want to configure is DB1200F128. Concerning the Type I thought of choosing Floating-> Is that right ? Yes
     -If I want to read an Integer, at address 30, in the DB20, the Address I want to configure is DB20W30. Concerning the Type I thought of choosing Integer-> Is that right ?
I think it will rather be DB20S30
     -If I want to read a Boolean, at address 4, in the DB46, the Address I want to configure is DB46B4. Concerning the Type I thought of choosing Boolean-> Is that right ?

You cannot read the boolean this way.

Extract from the Reference Guide :

In any Memory Type (excluding Counter and Timer), it is possible to access a single bit.

A #x must be appended to the Value name.
As the address is always in byte, the Bit index goes only from 0 to 7, no Modifer are allowed (except B to separate DB block from the
address).
The syntax can be used for reading bits and for writing them as well.
If Tag type “Automatic” is used, the type Boolean will be choosed

So you will have probably to do DB46B0#4
Reply

a123456789Z Offline
Member
#3
Thanks ! 

Last question about the I/O Server (The PLC communicate with PROFINET, with IP adress 192.168.0.1). Correct configuration is ISOTCP,192.168.0.1,03.01 , isn't it?
Reply

simon Offline
eWON Support
#4
Exactly :-)
See https://websupport.ewon.biz/support/prod...-1500-vipa
Reply

a123456789Z Offline
Member
#5
Hi,


The Ewon is ready, but the communication it's not possible...So I have a new question : 
What do I have to configure in the PLC ? 
          -Check "Permit acess with PUTGET communication from remote partner (PLC, HMI, OPC...) ?
          -Create a new "S7 connection" with the Ewon ? 

Here's my logs :
[Image: 1524647166409873480.jpg]


Thank you a lot
Reply

simon Offline
eWON Support
#6
Hi,

Yes, you have to check "Permit acess with PUTGET communication from remote partner (PLC, HMI, OPC...)
See end of https://websupport.ewon.biz/support/prod...-1500-vipa
Reply

a123456789Z Offline
Member
#7
(25-04-2018, 12:25 PM)Simon Wrote: Hi,

Yes, you have to check "Permit acess with PUTGET communication from remote partner (PLC, HMI, OPC...)
See end of https://websupport.ewon.biz/support/prod...-1500-vipa
Only that ?  I don't have to create a new connection as well ?


Thanks
Reply

simon Offline
eWON Support
#8
Yes, only this option is required.
The Flexy connection is seen as Step7/TIA connection and not as a fieldbus connection.
Reply

a123456789Z Offline
Member
#9
(25-04-2018, 03:55 PM)Simon Wrote: Yes, only this option is required.
The Flexy connection is seen as Step7/TIA connection and not as a fieldbus connection.

Ok, thank you a lot for the information !
Reply

Koos Offline
Junior Member
#10
(25-04-2018, 12:25 PM)Simon Wrote: Hi,

Yes, you have to check "Permit acess with PUTGET communication from remote partner (PLC, HMI, OPC...)
See end of https://websupport.ewon.biz/support/prod...-1500-vipa

Hi Simon,

we've got the same issue here with a Flexy 205 and th setting for the PUTGET is checked already in the TIAPortal. Still got the error:

S74srv-Invalid DataType in read response

I also added the tag 'Status', which gives a value '2', which is not ok.

Do you have any suggestions how to solve it?
Reply

simon Offline
eWON Support
#11
Hi,

Did you send the program to the PLC after having set the option ?

If yes, I would suggest you contact your local distributor to get closer support.

Simon
Reply

Koos Offline
Junior Member
#12
(08-05-2018, 04:04 PM)Simon Wrote: Hi,

Did you send the program to the PLC after having set the option ?

If yes, I would suggest you contact your local distributor to get closer support.

Simon

It is fixed with the support of our local distributor. Thanks!
Reply

a123456789Z Offline
Member
#13
Hi,

I checked "Permit acess with PUTGET communication from remote partner (PLC, HMI, OPC...)" but it still does not work...(Socket error)


Did I forget something on the PLC ?
Reply

a123456789Z Offline
Member
#14
Hi,

I still have troubles to communicate with the S7-1200 (Socket error).

Configuration of the Ewon : 
https://www.noelshack.com/2018-24-2-1528790084-aa.jpg

Configuration of the PLC :
       -I checked "Permit access with PUT/GET communication"
       -On the network configuration, I put the address of the Ewon in the gateway 


But still does not work, and I don't understand why...

Do I have to use Gateway files founded here ? (https://websupport.ewon.biz/support/prod...-1500-vipa)
Reply

simon Offline
eWON Support
#15
No you do not need to use these files...

I suggest you contact your local distributor to get more help.
He will contact us if needed.
Reply





Users browsing this thread:
1 Guest(s)



Theme © Ewon 2019 - Forum software by © MyBB - Cookie policy