Ewon TechForum
Providing technical solutions to technical requests


Maximum Modbus RTU Device Connected to eWon
instruaravind Offline
Junior Member
#1
Hi Everyone,
Maximum how many Modbus RTU, we can connect to eWon to get the Data. 
Since there is only Three Topic, we can only create three Modbus RTU device, So Is there any other possibilities to connect more than 3 Devices???
Reply

simon Offline
eWON Support
#2
If you let the topic fields empty (Modbus ID and IP address), you can define them into the Tag address.
So it can be different for each tag you define.
Reply

instruaravind Offline
Junior Member
#3
(21-11-2016, 11:46 AM)Simon Wrote: If you let the topic fields empty (Modbus ID and IP address), you can define them into the Tag address.
So it can be different for each tag you define.

Yeah, I have checked.
But Is there any Limitations??? or 
We can Connect 255 Slaves???
Reply

simon Offline
eWON Support
#4
No there is no limitation. You can connect 253 slaves over Modbus RTU (serial connections) 
Over Modbus TCP, the limit is 32 slaves.
Reply

instruaravind Offline
Junior Member
#5
(21-11-2016, 01:02 PM)Simon Wrote: No there is no limitation. You can connect 253 slaves over Modbus RTU (serial connections) 
Over Modbus TCP, the limit is 32 slaves.

Thank you simon.
Reply

irshadhashim Offline
Junior Member
#6
Hi Simon.
The configuration you suggested is not working for me.
I just kept the topic configuration in MODBUS IO Server empty and tried to read the data from a Modbus TCP device using below addressing method:
"40001,1,192.168.1.107", tried to read register 40001 from device IP 192.168.1.107 with a unit ID of 1.
But it doesn't work for me.

To confirm the issue, I just configured the topic A as Unit ID=1, IP Address=192.168.1.107, and selected Topic A while creating the tag; it works and able to read the data.

Please look into this matter.

Regards,
Irshad Hashim
Reply

simon Offline
eWON Support
#7
Irshad,

That's strange. This syntax should work.
What error do you see in the logs ? Can you send me your Config.txt ?

Regards
Reply

Francesco Offline
Junior Member
#8
(21-11-2016, 01:02 PM)Simon Wrote: No there is no limitation. You can connect 253 slaves over Modbus RTU (serial connections) 
Over Modbus TCP, the limit is 32 slaves.

Hi Simon,
do you confirm that Modbus TCP slaves limit is 32? What about irshadhashim error?
Thank you.
Reply

simon Offline
eWON Support
#9
Yes, it is well 32 slaves.
Irshad has not come back to me so far...
Reply

Francesco Offline
Junior Member
#10
(08-05-2018, 05:58 AM)Simon Wrote: Yes, it is well 32 slaves.
Irshad has not come back to me so far...

Thank you Simon.
Bye.
Reply

Hemant Jhamnani Offline
Ewon Distributor
#11
(21-11-2016, 01:02 PM)simon Wrote: No there is no limitation. You can connect 253 slaves over Modbus RTU (serial connections) 
Over Modbus TCP, the limit is 32 slaves.

Hey Simon, 

If i am connecting more than 2 devices over serial port in ewon there comes no communication error randomly.
sometimes all the 5 devices gives response after poll and then after sometime the devices show no communication.
Do you know the reason? i have changed the poll rates of all devices and checked also but the same error continues..
Reply

polishglider Offline
Junior Member
#12
Hi,
Have you set the options PreDelayVal, MaxDeltaRegX and MaxDeltaCoilX in your modbus server ?

regards
Reply

Hemant Jhamnani Offline
Ewon Distributor
#13
(12-02-2019, 01:11 PM)polishglider Wrote: Hi,
Have you set the options PreDelayVal, MaxDeltaRegX and MaxDeltaCoilX in your modbus server ?

regards


Hi,

Yeah I set now the parameters as: PreDelayVal: 7000, MaxDeltaRegX: 5 and MaxDeltaCoilX: not put anything in modbus server,
I have tried random values in these parameters but not the issues continues to be there. 
i have connected 5 devices in loop with slave id as 5,7,10,11,12 in ewon tags.
but there comes error as "No communication" randomly in values.
Reply

Hemant Jhamnani Offline
Ewon Distributor
#14
Hi,

Yeah I set now the parameters as: PreDelayVal: 7000, MaxDeltaRegX: 5 and MaxDeltaCoilX: not put anything in modbus server,
I have tried random values in these parameters but not the issues continues to be there.
i have connected 5 devices in loop with slave id as 5,7,10,11,12 in ewon tags.
but there comes error as "No communication" randomly in values.
Reply

simon Offline
eWON Support
#15
Hi,

The X in the MaxDeltaRegX and MaxDeltaCoilX parameters must be replaced by the topic letter (ex : MaxDeltaRegA : 5)
You can activate the serial debug, simulate the problem, make a full backup (with support files) and open a support ticket.
We will analyze the logs.

Simon
Reply



Possibly Related Threads…
12-11-2019, 02:52 PM
Last Post: AlexV
07-11-2019, 05:03 PM
Last Post: simon
  Double Float via Modbus Started by alex barnaba
2 Replies - 2.857 Views
11-10-2019, 09:14 AM
Last Post: Diksha.Saxena
04-10-2019, 09:26 AM
Last Post: djonedd
15-08-2019, 02:26 PM
Last Post: schlottke
29-07-2019, 04:45 PM
Last Post: simon
  Modbus ASCII IOServer for eWON Started by simon
8 Replies - 6.083 Views
22-07-2019, 01:33 PM
Last Post: simon
28-06-2019, 10:31 AM
Last Post: simon
28-05-2019, 01:22 AM
Last Post: numb
23-05-2019, 03:14 AM
Last Post: Josh



Users browsing this thread:
1 Guest(s)



Theme © Ewon 2019 - Forum software by © MyBB - Cookie policy